Email messages not being delivered due to Microsoft Exchange fault

Down Email
2022-01-01 21:23 BST · 34 minutes

Update

Resolved

Fix in place, email messages now being delivered. Many messages sent since midnight will be delayed, delivery should take place over next 24 hours.

January 1, 2022 · 21:57 BST
Monitoring

Fix in place, email messages now being delivered. Many messages sent since midnight will be delayed, delivery should take place over next 24 hours.

January 1, 2022 · 21:56 BST
Issue

NDPH email affected by common Exchange bug https://techcommunity.microsoft.com/t5/exchange-team-blog/email-stuck-in-transport-queues/ba-p/3049447 - IT Operations team investigating.

January 1, 2022 · 21:24 BST

← Back