Outlook issues

Down Email
2021-09-27 08:19 BST · 21 minutes

Update

Resolved

We believe this is now resolved.
If you are still having any issues please log them in the normal way

November 4, 2021 · 15:25 BST
Issue

There is an issue with Outlook for some users, please use Webmail as a work around

November 4, 2021 · 15:25 BST

← Back