Sky broadband affecting internet for many staff

Degraded Network connectivity
2021-08-20 10:08 BST · 6 hours, 27 minutes

Update

Resolved

Sky indicate issues resolved, customers may need a router reboot.

November 4, 2021 · 15:25 BST
Issue

Although there are no faults with the University or NDPH networks, there are a lot of reports of issues for Sky broadband customers. Issue seems to be intermittent. You may find that restarting your router clears the problem.

November 4, 2021 · 15:25 BST

← Back