Email webmail issues

Degraded Email
2021-08-18 11:59 BST · 2 hours, 17 minutes

Update

Resolved

We believe this has been resolved, if you are still having issues please log them in the normal way.

November 4, 2021 · 15:25 BST
Issue

An issue with one of our backend email servers means that webmail may not be working for some staff. IT team are investigating. If you experience issues, please try again in a few minutes.

November 4, 2021 · 15:25 BST

← Back