Some J: and K: drives unavailable
Down
Network drives J: K:
2021-06-14 10:08 BST
· 34 minutes
Update
Resolved
November 4, 2021 · 15:25 GMT
UPDATE: This issue is now fixed. Anyone with outstanding issues should report these in the usual manner.
Monitoring
November 4, 2021 · 15:25 GMT
UPDATE: This issue is now fixed. Anyone with outstanding issues should report these in the usual manner.
← Back