Outlook security alert: certificate warning

Degraded Email
2021-03-18 09:20 BST · 1 day, 4 hours, 55 minutes

Update

Resolved

There should be no certificate/security warnings when starting Outlook any more. Please report any ongoing issues in the usual manner.

November 4, 2021 · 15:25 BST
Investigating

Users may see a security alert message this morning when starting Outlook. On this occasion it is safe to say ‘Yes’ to proceed. This issue should be fixed within the next few hours, apologies for confusion.

16:40 Thursday This issue is still outstanding and we hope will be fully fixed Friday morning, apologies for any ongoing confusion.

November 4, 2021 · 15:25 BST
Issue

Users may see a security alert message this morning when starting Outlook. On this occasion it is safe to say ‘Yes’ to proceed. This issue should be fixed within the next few hours, apologies for confusion.

November 4, 2021 · 15:25 BST

← Back