Some J: and K: drives currently not working

Down Network drives J: K:
2021-02-11 08:16 BST · 15 minutes

Update

Resolved

Isssue has now been resolved

November 4, 2021 · 15:24 BST
Issue

Some users are experiencing a loss of access to J: and K: drives.
IT are aware and are investigating

November 4, 2021 · 15:24 BST

← Back