IT Service Desk system is currently down

Down Other
2026-08-21 10:42 BST · 5 hours, 57 minutes

Update

Resolved

The Service Desk is now back.

August 21, 2026 · 15:40 BST
Issue

The NDPH IT Service Desk system is currently down and a support ticket is now opened with the vendor.

August 21, 2026 · 10:42 BST

← Back