Helpdesk down
Down
Other
2026-06-29 08:23 BST
· 6 hours, 22 minutes
Update
Resolved
June 29, 2026 · 14:44 BST
Service Desk appears to now running normally again, we are monitoring its behaviour. Please use it in the normal way, thanks for your patience during the outage.
Monitoring
June 29, 2026 · 14:43 BST
Service Desk appears to now running normally again, we are monitoring its behaviour. Please use it in the normal way, thanks for your patience during the outage.
Issue
June 29, 2026 · 08:23 BST
The IT part of the Helpdesk is not available (http://help.ndph.ox.ac.uk), this is being investigated
← Back
System Status