Network outage to part of BDI Level 2

Down Network connectivity
2026-01-20 09:18 GMT · 4 hours, 35 minutes

Update

Resolved

Power fully restored approx. 13:30.

January 20, 2026 · 13:53 GMT
Monitoring

Power fully restored approximately 13:30.

January 20, 2026 · 13:53 GMT
Investigating

Nature of the power fault affecting BDI Level 2 has been identified, power expected to be restored approximately 13:00.

January 20, 2026 · 10:11 GMT
Issue

Due to a power failure there is no network connectivity on BDI Level 2. Facilities and IT teams are investigating.

January 20, 2026 · 09:18 GMT

← Back