Network fault, RDB and BDI
Down
Network connectivity
Virtual Desktop service
Network drives J: K:
Other
2026-01-06 14:16 GMT
· 41 minutes
Update
Resolved
January 6, 2026 · 14:56 GMT
This networking issue has been resolved and all systems should be functioning normally.
If you have any persisting issues please reboot your PC first before contacting the service desk
Issue
January 6, 2026 · 14:16 GMT
Various systems might appear to be down or unreachable. Infrastructure team investigating.
← Back
System Status