Email: delays to some messages
Degraded
Email
2020-10-21 16:44 BST
· 1 day, 23 hours, 55 minutes
Update
Resolved
November 4, 2021 · 15:24 GMT
Investigations into some delayed & undelivered email during Wednesday identified a possible storage fault, which has been addressed.
Investigating
November 4, 2021 · 15:24 GMT
Investigations into some delayed & undelivered email identified a possible storage fault, which has been addressed. Queued messages may now start being delivered, although this might take some hours.
Issue
November 4, 2021 · 15:24 GMT
We are investigating reports of some delayed & undelivered email, affecting a small proportion of messages/users. Most seem unaffected, however.
← Back