Virtual Desktop Conneciton issues

Down Virtual Desktop service
2020-09-24 15:22 BST · 20 hours, 12 minutes

Update

Resolved

A fault was discovered with the configuration on one of our Virtual Desktop systems following a recent hardware expansion to support more users, this has been corrected. Please report via the usual channels if you are experiencing ongoing issues.

November 4, 2021 · 15:24 BST
Issue

Some people are having difficulty connecting or being disconnected from their Virtual Desktops, we are currently investigating

November 4, 2021 · 15:24 BST

← Back