Serious incident affecting email for some users & Virtual Desktops

Down Virtual Desktop service
2020-09-18 07:43 BST · 2 hours, 27 minutes

Update

Resolved

Virtual Desktops should be working again but might be slow at first.

November 4, 2021 · 15:24 BST
Monitoring

Virtual Desktops should be working again but might be slow at first.

November 4, 2021 · 15:24 BST
Issue

Earlier issue with email is now resolved, outstanding issue with Virtual Desktops remains.

November 4, 2021 · 15:24 BST

← Back