Security certificate alert in Outlook

Degraded Email
2025-02-12 11:55 GMT · 1 day, 1 hour, 33 minutes

Update

Resolved

This issue has been fixed, there is now a new Security Certificate in place.

February 13, 2025 · 13:27 GMT
Issue

There is a fault on the NDPH email server which is provoking a Security Alert, noting that the security certificate is invalid. This is an error and not malicious, it is safe to click ‘Yes’.

February 12, 2025 · 11:55 GMT

← Back