K: drive not working

Down Network drives J: K:
2020-07-09 08:44 BST · 18 minutes

Update

Resolved

The issue with the K: drive has been resolved

November 4, 2021 · 15:24 BST
Issue

The K: drive is currently not working.
IT are investigating

November 4, 2021 · 15:24 BST

← Back