External email not being delivered to Nexus365

Degraded Email
2023-10-09 10:00 BST · 3 hours, 28 minutes

Update

Resolved

Central IT says: “The mail delivery issue has been identified and resolved. Mail delivery in and out of Nexus 365 was being impacted, causing mail to queue. The mail flow has been reinstated and queued mail is now being delivered.”

To add: this means that messages will be delivered, but with a delay as the queue clears.

October 9, 2023 · 13:27 BST
Monitoring

[Update] The mail delivery issue has been identified and resolved. Mail delivery in and out of Nexus 365 was being impacted, causing mail to queue. The mail flow has been reinstated and queued mail is now being delivered.
To add: this means that messages will be delivered, but with a delay as the queue clears.

October 9, 2023 · 12:00 BST
Monitoring

Central University IT says: “IT Services are investigating an issue where email from external addresses are not being delivered into Nexus365.”

October 9, 2023 · 11:00 BST

← Back