EDMS is down

Degraded Other
2023-10-02 09:00 BST · 4 hours, 58 minutes

Update

Resolved

EDMS service has been restored.

October 2, 2023 · 13:58 BST
Issue

EDMS is down, investigation underway.

October 2, 2023 · 11:42 BST

← Back