Power outage to some areas of RDB Level 2

Degraded Network connectivity Other
2023-06-29 08:11 BST · 51 minutes

Update

Resolved

Overnight power cut tripped some electrical circuits, these have been reset by Facilities approx 08:45. Please report any ongoing issues in the usual way.

June 29, 2023 · 09:02 BST
Issue

Overnight power cut appears to have tripped some electrical circuits. Awaiting Facilities to reset.

June 29, 2023 · 08:11 BST

← Back