Slow internet connections from Virgin Media

Degraded VPN Virtual Desktop service
2020-05-29 10:59 BST · 2 days, 22 hours, 25 minutes

Update

Resolved

Numerous anecdotal reports (and the personal experience of members of the IT team) suggest that the issue with Virgin Media broadband cleared during the course of Friday.

November 4, 2021 · 15:24 BST
Issue

We have been informed that there are problems connecting from Virgin Media to all Oxford University services.

JISC (who provide Internet services to the University) has contacted Virgin Media about this

November 4, 2021 · 15:24 BST

← Back