Virtual Desktop Conneciton issues

Down Virtual Desktop service
2020-05-28 10:04 BST · 32 minutes

Update

Resolved

This appears to be working, and related to Windows updates being applied on the Virtual desktops

November 4, 2021 · 15:24 BST
Issue

Some people are having issues connecting to virtual desktops, this is being investigated

November 4, 2021 · 15:24 BST

← Back