FAULT: Virtual Desktop service intermittent problems continuing

Down Virtual Desktop service
2020-05-05 14:33 BST · 1 hour, 15 minutes

Update

Resolved

Virtual Desktop system is working again. We are still working to identify the underlying fault, the fault which may cause a recurrence in future.

November 4, 2021 · 15:24 BST
Investigating

There are ongoing issues with the Virtual Desktop service which we are investigating. Apologies, we appreciate that this is affecting a lot of people, but the root cause of the fault is not clear at the moment. IT staff are investigating as a matter of priority.

November 4, 2021 · 15:24 BST

← Back