Upstream issue with Microsoft 365

Degraded Email
2023-01-25 08:18 BST · 4 hours, 47 minutes

Update

Resolved

Upstream status page suggest issue is resolved. If you have ongoing issues, please contact Helpdesk in the usual way.

January 25, 2023 · 13:06 BST
Issue

Upstream issue affecting MIcrosoft 365 email/calendar services, OneDrive, Teams, Sharepoint and authentication. See https://status.office.com/

January 25, 2023 · 08:23 BST

← Back